FireFox 96.0.x does not transmit video or screen share (fix is coming)
Incident Report for Blindside Networks
Resolved
We have deployed the fix to resolve issues with sharing video in FireFox 96.
Posted Jan 17, 2022 - 12:41 UTC
Monitoring
We have detected an issue with FireFox 96.0.x that is preventing it from transmitting webcam or screen share to other users in a session (or to the server for recoding). We have a fix ready and are deploying it to our infrastructure. Until fully deployed (we'll update this incident when deployed), we recommend users use Chrome instead when sharing webcams or screen.
Posted Jan 14, 2022 - 20:57 UTC
This incident affected: Client.